Инструменты пользователя

Инструменты сайта


1s_8:accounting30:disable_window_udate_config

Отключение уведомления "Рекомендуется обновить версию конфигурации" в БП 3.0

FIXME

Многим надоело сообщение о необходимости обновления версии конфигурации.

1С Бухгалтерия предприятия, редакция 3.0

Внешний вид окна с сообщение которое выдаётся пользователю:

Внешний вид окна с сообщение которое выдаётся администратору:

Здесь я описываю один из вариантов отключения этого сообщения.

Для этого нужно внести изменения в Общий модуль ОбщегоНазначенияБП

Исправление

Нужно внести изменение в функцию ПредлагатьОбновитьВерсиюПрограммы модуля Общий модуль ОбщегоНазначенияБП

Пример исправленного кода модуля:

Функция ПредлагатьОбновитьВерсиюПрограммы(Параметры)
 
	Если ОбщегоНазначенияПовтИсп.РазделениеВключено() Тогда
		Возврат Ложь;
	КонецЕсли;
 
	Параметры.Вставить("ЭтоАдминистраторСистемы", ОбщегоНазначенияПовтИсп.РежимРаботыПрограммы().ЭтоАдминистраторСистемы);
	ДатаТекущейВерсии = Константы.ДатаТекущейВерсии.Получить();
	НадоПредлагать = ЗначениеЗаполнено(ДатаТекущейВерсии) 
		И ТекущаяДатаСеанса() > ДобавитьМесяц(ДатаТекущейВерсии, 2);
	НадоПредлагать = Ложь; // Отключение уведомления "Рекомендуется обновить версию конфигурации"
	Возврат НадоПредлагать;
 
КонецФункции

В оригинальный код добавлена строка:

	НадоПредлагать = Ложь; // Отключение уведомления "Рекомендуется обновить версию конфигурации"

Код для расширения

Наиболее правильным вариантом будет создать расширение для объекта Общий модуль.ОбщегоНазначенияБП и создать в нём собственный вариант функции ПредлагатьОбновитьВерсиюПрограммы

Вот готовый код для модуля расширения:

#Область Описание
 
// Отключение уведомления "Рекомендуется обновить версию конфигурации"
 
#КонецОбласти
 
&Вместо("ПредлагатьОбновитьВерсиюПрограммы")
Функция Д1_ПредлагатьОбновитьВерсиюПрограммы(Параметры)
 
	Если ОбщегоНазначенияПовтИсп.РазделениеВключено() Тогда
		Возврат Ложь;
	КонецЕсли;
 
	Параметры.Вставить("ЭтоАдминистраторСистемы", ОбщегоНазначенияПовтИсп.РежимРаботыПрограммы().ЭтоАдминистраторСистемы);
	ДатаТекущейВерсии = Константы.ДатаТекущейВерсии.Получить();
	НадоПредлагать = ЗначениеЗаполнено(ДатаТекущейВерсии) 
		И ТекущаяДатаСеанса() > ДобавитьМесяц(ДатаТекущейВерсии, 2);
	НадоПредлагать = Ложь; // Отключение уведомления "Рекомендуется обновить версию конфигурации"
	Возврат НадоПредлагать;
 
КонецФункции

После подключения расширения нужно отключить для него Безопасный режим и Защита от опасных действий

Ссылки

1s_8/accounting30/disable_window_udate_config.txt · Последние изменения: 2018-02-03 16:12 — GreyWolf